Fluctuating RPM

Joined
Nov 11, 2021
Messages
40
Don't remember this issue previously. But getting some pretty drastic rpm fluctuations. Thought it was a loose connection but it showed up again. Fluctuations go from 2850-2200 pretty rapidly.

Plane didn't fly much from July until it was flown to annual and that's where I first saw the fluctuations. It went to 2800 once briefly. Had me thinking over sped the prop. First flight post annual had fluctuations 2850-2200 pretty rapidly. A&p found a connection that looked suspect. Yesterday's flight it was acting up again. Reading a little more on it it could be a magneto? Not sure how the Dynon gets the rpm, would this be the old p-leads not being up to snuff shielding wise?
 

jakej

Well-Known Member
Joined
Oct 10, 2007
Messages
2,074
Location
Adelaide, Australia
Don't remember this issue previously. But getting some pretty drastic rpm fluctuations. Thought it was a loose connection but it showed up again. Fluctuations go from 2850-2200 pretty rapidly.

Plane didn't fly much from July until it was flown to annual and that's where I first saw the fluctuations. It went to 2800 once briefly. Had me thinking over sped the prop. First flight post annual had fluctuations 2850-2200 pretty rapidly. A&p found a connection that looked suspect. Yesterday's flight it was acting up again. Reading a little more on it it could be a magneto? Not sure how the Dynon gets the rpm, would this be the old p-leads not being up to snuff shielding wise?
If it’s a Lycoming or clone then check the resistor (should be ~30kOhm) in the wires tach wires (green/white or blue/white) going from the Dynon EMS to each P-lead.
 

M20Driver

Member
Joined
Jan 16, 2021
Messages
36
Don't remember this issue previously. But getting some pretty drastic rpm fluctuations. Thought it was a loose connection but it showed up again. Fluctuations go from 2850-2200 pretty rapidly.

Plane didn't fly much from July until it was flown to annual and that's where I first saw the fluctuations. It went to 2800 once briefly. Had me thinking over sped the prop. First flight post annual had fluctuations 2850-2200 pretty rapidly. A&p found a connection that looked suspect. Yesterday's flight it was acting up again. Reading a little more on it it could be a magneto? Not sure how the Dynon gets the rpm, would this be the old p-leads not being up to snuff shielding wise?
A few years ago I had rapid RPM spikes occasionally. P leads were new, connections all checked, nothing. Then I lost a mag. It ran rough with both mags, and I noticed the rpm was really all over the place (over redline which the engine wasnt) I couldnt find anything suspect inside the mag visually, but swapped in a surefly and an OH Bendix. Rpm spikes gone. I suspect it was arcing internally causing the spikes
 
Top